2/2/2012

How To Nvidia legacy Fedora 16 - Xorg 1.11 [SOLVED]

Me enteré los otros días, que en Fedora 16, están teniendo problemas con las placas algo viejitas de Nvidia, dado que el driver kmod o akmod, no inician las X, incluso los legacy 173.x.
Me puse a leer un poco y es un problema de Nvidia basicamente.
El tema es que Nvidia, no actualizó los driver ni binarios ni nada, para la nueva version de Xorg 1.11, donde los viejos driver, no funcionan, si los nuevos, asi que por lo que vi, no queda más que usar Nouveau, con lo que ello representa, o sea, no tener aceleracion 3D en muchos casos, o tenerla pero con un bajo rendimiento.
La pregunta es, solución?, si, la hay, pero no es para gente que se vaya a asustar o inexpertos que no lean bien, asi que ya saben, si rompen algo, es porque no leyeron bien o no saben que es un terminal o un tty.
Primero que nada, aclaro que el comando yum downgrade xorg no sirve, dado que baja de la 1.11.3 a la 1.11.1 de Xorg, nosotros buscamos la 1.10.x, que es donde aun funcionaban los binarios de Nvidia.
Para ello, debemos de eliminar Xorg y sus dependencias e instalar a mano, el Xorg mas viejo, que no tiene conflicto alguno.
Primero que nada, bajamos los RPM desde Koji, el Buildsystem de Fedora, los paquetes a bajar son:

Para 32 bit:

http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/i686/xorg-x11-server-Xdmx-1.10.4-1.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/i686/xorg-x11-server-Xephyr-1.10.4-1.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/i686/xorg-x11-server-Xnest-1.10.4-1.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/i686/xorg-x11-server-Xorg-1.10.4-1.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/i686/xorg-x11-server-Xvfb-1.10.4-1.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/i686/xorg-x11-server-common-1.10.4-1.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/i686/xorg-x11-server-devel-1.10.4-1.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/i686/xorg-x11-server-debuginfo-1.10.4-1.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-keyboard/1.5.0/4.20101201.fc15/i686/xorg-x11-drv-keyboard-1.5.0-4.20101201.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-keyboard/1.5.0/4.20101201.fc15/i686/xorg-x11-drv-keyboard-debuginfo-1.5.0-4.20101201.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-v4l/0.2.0/10.fc15/i686/xorg-x11-drv-v4l-0.2.0-10.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-v4l/0.2.0/10.fc15/i686/xorg-x11-drv-v4l-debuginfo-0.2.0-10.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-mouse/1.6.99.901/2.fc15/i686/xorg-x11-drv-mouse-1.6.99.901-2.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-mouse/1.6.99.901/2.fc15/i686/xorg-x11-drv-mouse-debuginfo-1.6.99.901-2.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-dummy/0.3.4/5.fc15/i686/xorg-x11-drv-dummy-0.3.4-5.fc15.i686.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-dummy/0.3.4/5.fc15/i686/xorg-x11-drv-dummy-debuginfo-0.3.4-5.fc15.i686.rpm


Para 64 bit:

http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/x86_64/xorg-x11-server-Xdmx-1.10.4-1.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/x86_64/xorg-x11-server-Xephyr-1.10.4-1.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/x86_64/xorg-x11-server-Xnest-1.10.4-1.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/x86_64/xorg-x11-server-Xorg-1.10.4-1.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/x86_64/xorg-x11-server-Xvfb-1.10.4-1.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/x86_64/xorg-x11-server-common-1.10.4-1.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/x86_64/xorg-x11-server-devel-1.10.4-1.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/x86_64/xorg-x11-server-debuginfo-1.10.4-1.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-keyboard/1.5.0/4.20101201.fc15/x86_64/xorg-x11-drv-keyboard-1.5.0-4.20101201.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-keyboard/1.5.0/4.20101201.fc15/x86_64/xorg-x11-drv-keyboard-debuginfo-1.5.0-4.20101201.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-v4l/0.2.0/10.fc15/x86_64/xorg-x11-drv-v4l-0.2.0-10.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-v4l/0.2.0/10.fc15/x86_64/xorg-x11-drv-v4l-debuginfo-0.2.0-10.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-mouse/1.6.99.901/2.fc15/x86_64/xorg-x11-drv-mouse-1.6.99.901-2.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-mouse/1.6.99.901/2.fc15/x86_64/xorg-x11-drv-mouse-debuginfo-1.6.99.901-2.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-dummy/0.3.4/5.fc15/x86_64/xorg-x11-drv-dummy-0.3.4-5.fc15.x86_64.rpm
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-dummy/0.3.4/5.fc15/x86_64/xorg-x11-drv-dummy-debuginfo-0.3.4-5.fc15.x86_64.rpm

Y el ultimo, noarch (o sea, va para todos en común)

http://kojipkgs.fedoraproject.org/packages/xorg-x11-server/1.10.4/1.fc15/noarch/xorg-x11-server-source-1.10.4-1.fc15.noarch.rpm

Una vez que bajaron todo eso, por ej a /root/xorg_legacy/, se disponen a reiniciar el sistema e iniciar en runlevel 3, o sea, sin X. Como?, facil, reinician, en el menu de GRUB, ponen editar, y en la ultima linea del kernel, colocan un 3, con eso le indican que inicie en runlevel 3, que es con red pero sin grafica.
Luego de ello, se loguean en una tty, que para el que no lo sabe, es una terminal no grafica, ingresan como root, y proceden a hacer esto:

yum remove xorg-x11-server-Xorg

Eso les va a dar una salida como esta:


Complementos cargados:changelog, langpacks, presto, refresh-packagekit, remove-with-leaves, show-leaves
Configurando el proceso de eliminación
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Paquete xorg-x11-server-Xorg.x86_64 0:1.11.3-1.fc16 debe ser eliminado
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-qxl-0.0.21-8.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-rendition-4.2.4-7.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-glint-1.2.5-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-siliconmotion-1.7.5-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-vmmouse-12.7.0-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-dummy-0.3.4-7.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-savage-2.3.3-1.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-sisusb-0.9.4-7.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-i128-1.3.4-9.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-nv-2.1.18-8.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-s3virge-1.10.4-9.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-r128-6.8.1-11.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-tdfx-1.4.3-9.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-voodoo-1.2.4-7.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-sis-0.10.3-7.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-vmware-11.0.3-6.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-evdev-2.6.99-3.20110601giteaf202531.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-synaptics-1.5.0-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-trident-1.3.4-7.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-fpit-1.4.0-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-mouse-1.7.1-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-elographics-1.3.0-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-apm-1.2.3-8.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-mutouch-1.3.0-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-hyperpen-1.4.1-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-v4l-0.2.0-14.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-ast-0.91.10-7.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-fbdev-0.4.2-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-ati-6.14.3-3.20111125git534fb6e41.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-aiptek-1.4.1-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-acecad-1.5.0-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-void-1.4.0-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-i740-1.3.2-9.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-vesa-2.3.0-9.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-intel-2.17.0-4.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-mach64-6.9.0-2.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-penmount-1.5.0-3.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-openchrome-0.2.904-16.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-cirrus-1.3.2-10.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-mga-1.4.13-8.fc16.x86_64
--> Procesando dependencias: Xorg para el paquete: xorg-x11-drv-keyboard-1.6.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-qxl-0.0.21-8.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-rendition-4.2.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-glint-1.2.5-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-siliconmotion-1.7.5-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-vmmouse-12.7.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-dummy-0.3.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-savage-2.3.3-1.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-sisusb-0.9.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-i128-1.3.4-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-nv-2.1.18-8.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-s3virge-1.10.4-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-r128-6.8.1-11.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-tdfx-1.4.3-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-voodoo-1.2.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-sis-0.10.3-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-vmware-11.0.3-6.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-evdev-2.6.99-3.20110601giteaf202531.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-synaptics-1.5.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-trident-1.3.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-fpit-1.4.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-mouse-1.7.1-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-elographics-1.3.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-apm-1.2.3-8.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-mutouch-1.3.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-hyperpen-1.4.1-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-v4l-0.2.0-14.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-ast-0.91.10-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-fbdev-0.4.2-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-ati-6.14.3-3.20111125git534fb6e41.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-aiptek-1.4.1-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-acecad-1.5.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-void-1.4.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-i740-1.3.2-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-vesa-2.3.0-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-intel-2.17.0-4.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-mach64-6.9.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-penmount-1.5.0-3.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-openchrome-0.2.904-16.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-cirrus-1.3.2-10.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-mga-1.4.13-8.fc16.x86_64
--> Procesando dependencias: xserver-abi(ansic-0) >= 4 para el paquete: xorg-x11-drv-keyboard-1.6.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-rendition-4.2.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-glint-1.2.5-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-qxl-0.0.21-8.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-savage-2.3.3-1.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-sisusb-0.9.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-i128-1.3.4-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-nv-2.1.18-8.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-s3virge-1.10.4-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-r128-6.8.1-11.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-tdfx-1.4.3-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-voodoo-1.2.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-sis-0.10.3-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-vmware-11.0.3-6.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-siliconmotion-1.7.5-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-trident-1.3.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-dummy-0.3.4-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-apm-1.2.3-8.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-v4l-0.2.0-14.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-ast-0.91.10-7.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-fbdev-0.4.2-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-ati-6.14.3-3.20111125git534fb6e41.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-i740-1.3.2-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-vesa-2.3.0-9.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-intel-2.17.0-4.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-mach64-6.9.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-openchrome-0.2.904-16.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-cirrus-1.3.2-10.fc16.x86_64
--> Procesando dependencias: xserver-abi(videodrv-11) >= 0 para el paquete: xorg-x11-drv-mga-1.4.13-8.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-aiptek-1.4.1-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-synaptics-1.5.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-fpit-1.4.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-mouse-1.7.1-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-vmmouse-12.7.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-elographics-1.3.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-void-1.4.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-penmount-1.5.0-3.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-keyboard-1.6.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-mutouch-1.3.0-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-hyperpen-1.4.1-2.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-evdev-2.6.99-3.20110601giteaf202531.fc16.x86_64
--> Procesando dependencias: xserver-abi(xinput-13) >= 0 para el paquete: xorg-x11-drv-acecad-1.5.0-2.fc16.x86_64
--> Procesando dependencias: xorg-x11-server-Xorg >= 1.7.99 para el paquete: system-setup-keyboard-0.8.8-1.fc16.x86_64
--> Ejecutando prueba de transacción
---> Paquete system-setup-keyboard.x86_64 0:0.8.8-1.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-acecad.x86_64 0:1.5.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-aiptek.x86_64 0:1.4.1-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-apm.x86_64 0:1.2.3-8.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-ast.x86_64 0:0.91.10-7.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-ati.x86_64 0:6.14.3-3.20111125git534fb6e41.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-cirrus.x86_64 0:1.3.2-10.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-dummy.x86_64 0:0.3.4-7.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-elographics.x86_64 0:1.3.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-evdev.x86_64 0:2.6.99-3.20110601giteaf202531.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-fbdev.x86_64 0:0.4.2-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-fpit.x86_64 0:1.4.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-glint.x86_64 0:1.2.5-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-hyperpen.x86_64 0:1.4.1-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-i128.x86_64 0:1.3.4-9.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-i740.x86_64 0:1.3.2-9.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-intel.x86_64 0:2.17.0-4.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-keyboard.x86_64 0:1.6.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-mach64.x86_64 0:6.9.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-mga.x86_64 0:1.4.13-8.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-mouse.x86_64 0:1.7.1-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-mutouch.x86_64 0:1.3.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-nv.x86_64 0:2.1.18-8.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-openchrome.x86_64 0:0.2.904-16.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-penmount.x86_64 0:1.5.0-3.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-qxl.x86_64 0:0.0.21-8.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-r128.x86_64 0:6.8.1-11.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-rendition.x86_64 0:4.2.4-7.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-s3virge.x86_64 0:1.10.4-9.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-savage.x86_64 0:2.3.3-1.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-siliconmotion.x86_64 0:1.7.5-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-sis.x86_64 0:0.10.3-7.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-sisusb.x86_64 0:0.9.4-7.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-synaptics.x86_64 0:1.5.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-tdfx.x86_64 0:1.4.3-9.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-trident.x86_64 0:1.3.4-7.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-v4l.x86_64 0:0.2.0-14.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-vesa.x86_64 0:2.3.0-9.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-vmmouse.x86_64 0:12.7.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-vmware.x86_64 0:11.0.3-6.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-void.x86_64 0:1.4.0-2.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-voodoo.x86_64 0:1.2.4-7.fc16 debe ser eliminado
---> Paquete xorg-x11-drv-wacom.x86_64 0:0.12.0-1.fc16 debe ser eliminado
--> Resolución de dependencias finalizada

Dependencias resueltas

=================================================================================================================================================================================
 Paquete                                          Arquitectura                 Versión                                                   Repositorio                       Tamaño
=================================================================================================================================================================================
Eliminando:
 xorg-x11-server-Xorg                             x86_64                       1.11.3-1.fc16                                             @updates                          3.7 M
Eliminando para las dependencias:
 system-setup-keyboard                            x86_64                       0.8.8-1.fc16                                              @anaconda-0                        15 k
 xorg-x11-drv-acecad                              x86_64                       1.5.0-2.fc16                                              @anaconda-0                        19 k
 xorg-x11-drv-aiptek                              x86_64                       1.4.1-2.fc16                                              @anaconda-0                        29 k
 xorg-x11-drv-apm                                 x86_64                       1.2.3-8.fc16                                              @anaconda-0                       134 k
 xorg-x11-drv-ast                                 x86_64                       0.91.10-7.fc16                                            @anaconda-0                        55 k
 xorg-x11-drv-ati                                 x86_64                       6.14.3-3.20111125git534fb6e41.fc16                        @updates                          1.2 M
 xorg-x11-drv-cirrus                              x86_64                       1.3.2-10.fc16                                             @anaconda-0                        86 k
 xorg-x11-drv-dummy                               x86_64                       0.3.4-7.fc16                                              @anaconda-0                        19 k
 xorg-x11-drv-elographics                         x86_64                       1.3.0-2.fc16                                              @anaconda-0                        20 k
 xorg-x11-drv-evdev                               x86_64                       2.6.99-3.20110601giteaf202531.fc16                        @anaconda-0                        55 k
 xorg-x11-drv-fbdev                               x86_64                       0.4.2-2.fc16                                              @anaconda-0                        24 k
 xorg-x11-drv-fpit                                x86_64                       1.4.0-2.fc16                                              @anaconda-0                        17 k
 xorg-x11-drv-glint                               x86_64                       1.2.5-2.fc16                                              @anaconda-0                       221 k
 xorg-x11-drv-hyperpen                            x86_64                       1.4.1-2.fc16                                              @anaconda-0                        19 k
 xorg-x11-drv-i128                                x86_64                       1.3.4-9.fc16                                              @anaconda-0                        61 k
 xorg-x11-drv-i740                                x86_64                       1.3.2-9.fc16                                              @anaconda-0                        49 k
 xorg-x11-drv-intel                               x86_64                       2.17.0-4.fc16                                             @updates                          787 k
 xorg-x11-drv-keyboard                            x86_64                       1.6.0-2.fc16                                              @anaconda-0                        24 k
 xorg-x11-drv-mach64                              x86_64                       6.9.0-2.fc16                                              @anaconda-0                       229 k
 xorg-x11-drv-mga                                 x86_64                       1.4.13-8.fc16                                             @anaconda-0                       173 k
 xorg-x11-drv-mouse                               x86_64                       1.7.1-2.fc16                                              @anaconda-0                        53 k
 xorg-x11-drv-mutouch                             x86_64                       1.3.0-2.fc16                                              @anaconda-0                        19 k
 xorg-x11-drv-nv                                  x86_64                       2.1.18-8.fc16                                             @anaconda-0                       215 k
 xorg-x11-drv-openchrome                          x86_64                       0.2.904-16.fc16                                           @anaconda-0                       460 k
 xorg-x11-drv-penmount                            x86_64                       1.5.0-3.fc16                                              @anaconda-0                        39 k
 xorg-x11-drv-qxl                                 x86_64                       0.0.21-8.fc16                                             @anaconda-0                       219 k
 xorg-x11-drv-r128                                x86_64                       6.8.1-11.fc16                                             @anaconda-0                       118 k
 xorg-x11-drv-rendition                           x86_64                       4.2.4-7.fc16                                              @anaconda-0                        45 k
 xorg-x11-drv-s3virge                             x86_64                       1.10.4-9.fc16                                             @anaconda-0                        80 k
 xorg-x11-drv-savage                              x86_64                       2.3.3-1.fc16                                              @updates                          151 k
 xorg-x11-drv-siliconmotion                       x86_64                       1.7.5-2.fc16                                              @anaconda-0                       121 k
 xorg-x11-drv-sis                                 x86_64                       0.10.3-7.fc16                                             @anaconda-0                       573 k
 xorg-x11-drv-sisusb                              x86_64                       0.9.4-7.fc16                                              @anaconda-0                        77 k
 xorg-x11-drv-synaptics                           x86_64                       1.5.0-2.fc16                                              @anaconda-0                       110 k
 xorg-x11-drv-tdfx                                x86_64                       1.4.3-9.fc16                                              @anaconda-0                        69 k
 xorg-x11-drv-trident                             x86_64                       1.3.4-7.fc16                                              @anaconda-0                       162 k
 xorg-x11-drv-v4l                                 x86_64                       0.2.0-14.fc16                                             @anaconda-0                        23 k
 xorg-x11-drv-vesa                                x86_64                       2.3.0-9.fc16                                              @anaconda-0                        28 k
 xorg-x11-drv-vmmouse                             x86_64                       12.7.0-2.fc16                                             @anaconda-0                        23 k
 xorg-x11-drv-vmware                              x86_64                       11.0.3-6.fc16                                             @anaconda-0                        63 k
 xorg-x11-drv-void                                x86_64                       1.4.0-2.fc16                                              @anaconda-0                        14 k
 xorg-x11-drv-voodoo                              x86_64                       1.2.4-7.fc16                                              @anaconda-0                        32 k
 xorg-x11-drv-wacom                               x86_64                       0.12.0-1.fc16                                             @updates                          709 k

Resumen de la transacción
=================================================================================================================================================================================
Remove       44 Packages

Tamaño instalado: 10 M
Está de acuerdo [s/N]:

Aceptan con "s", y eliminan xorg por completo.
Ahora bien, solo queda, ir a /root/xorg_legacy o donde hayan bajado los rpm mediante wget o curl, y hacer esto:

yum localinstall *.rpm, donde yum, va a instalar todos los rpm que esten ahi dentro, y no habrá problemas de dependencias, porque estan todas completas.
Luego de realizado esto, es MUY importante excluir Xorg en yum, para que no se actualice, sino todo habrá sido en vano, asi que vamos a editar yum.conf.

nano -c /etc/yum.conf

Y colocamos al final
exclude = xorg*

Guardamos con Ctrl+o y salimos como Ctrl+x.
Ahora bien, pueden chequear que al hacer yum update, no se actualiza nada.
Solo falta, instalar el akmod o kmod, asi que yum search nvidia, seleccionan el legacy de su placa, y hacen yum install, reinician, y deberian tener video con los driver viejitos. En caso de que no tengan grafica, vuelven a iniciar en runlevel 3, y logueados como root, ponen:

Xorg -configure, para recrear de nuevo el xorg.conf, que será dejado en /root/xorg.new.conf, asi que lo mueven con el comando mv, a /etc/X11/ con el nombre xorg.conf.

Espero les sirva, y no metan la pata, comentarios, sugerencias, problemas, etc, seran bienvenidos.

Saludos

1 comentario:

  1. Mil gracias!!!
    Error: Package: xorg-x11-drv-v41-0.2.2-10.fc15.i686 Requires: xserver-abi(videodrv-9) >= 0

    Use 0.2.2-12

    xorg-x11-drv-nvidia-173xx-l
    El kernel no es compatible (requiere 2.6.41 y tengo 3.2.6)

    ResponderEliminar

Ingresa tu comentario