RSS

 Seguime por RSS

9 oct. 2012

Firefox 16 update RHEL 6 - CentOS 6 - Scientific Linux 6

Hoy se liberó una actualización de Firefox, de la 15 a la 16.
Por lo que he probado, lo recomiendo, mejoró muchisimo la carga inicial, y la velocidad de carga de páginas.



Para actualizar en RHEL 6 y sus clones, sin tocar Thunderbird (a menos que deseen actualizar este tambien), los pasos a seguir son:

1.- # nano /etc/yum.repos.d/remi.repo

añadimos:
exclude=exclude=mysql* thunderbird*

2.- # yum --disablerepo "*" --enablerepo "remi" update

Es todo!.

Nota: Estos pasos son solo para los que tenian ya instalado firefox y SOLO firefox desde el repo remi, que se describe en este post. Para los demás, solo ejecuten 'yum --disablerepo "*" --enablerepo "remi" update firefox' si desean actualizar solo firefox desde ese repo ya instalado y no otras cosas.

Nota_2: Si no tenian el repo remi añadido, lean primero este post

9 comentarios:

  1. Hola

    Buena información, muchas gracias. Aunque sería mejor que agregues firefox al final de tu comando, ya que si tienes algún software que esté en Remi te lo va a actualizar. Quedaría mejor así:

    yum --disablerepo "*" --enablerepo "remi" update firefox

    Saludos, excelente blog !!

    ResponderEliminar
    Respuestas
    1. Es cierto, solo que no lo hice asi, dado que ya tenia instalado firefox desde REMI, y lo tengo en prioridad 6 el repo, asi que es imposible que pise los paquetes de la distro en si (tienen prioridad 1). REMI lo tengo solamente para firefox y 2-3 cosas más. De todos modos es buena idea, ahora agrego la data y aclaro que los que no lo tenian instalado desde el otro post sobre este mismo tema, deben hacer eso y solo eso.

      Eliminar
  2. SynFlag, me dirijo a tí porque veo que tienes gran gran experticia en hackear o afinar el sistema.
    Instalé centos6.3 porque ubuntu 12 es incómodo en su gnome modificado, a veces lo encuentro algo lento es su respuesta, busqué una distro seria, no me importa tener los úuultimos pqtes y el soporte hasta el año 2020 me dejó boquiabierto. Tb porque en algunos trabajos de mi área (telecomunicaciones) usan centos y puede resultar ventajoso conocer el sistema más de cerca.

    Instalé centos6.3, corre muy suave según veo, el gnome es clásico lo que es perfecto, instala pocas cosas que tb me parece estupendo, busqué un manual de yum y todo es muy lindo jajaja, instalé los repos rpmforge, puse el htop y el gimp, actualicé el sistema primero con la utilidad gráfica y luego verifiqué por consola con yum, me indica que está todo al día, tuve un problema en el camino y es que mi note no tiene batería, 2 veces mientras actualizaba se me apagó el note "a medio camino" (quizá 3/4 de camino) pero lo volví a correr hasta que pensé que el proceso terminó correctamente.

    Y aquí viene mi penuria, ahora quiero instalar audacious y me sale que necesita unos pqtes antiguos y mi sistema tiene unos más vos y no me deja instalar, ni con skip, no solo audacious, tb smplayer ni vlc player...

    SynFlag, te dejo una captura de consola para el caso de audacious, quizá para tí resulte obvia la solución si me pudieras dar alguna indicación de cómo solucionar que no puedo instalar programas...

    ........
    Error: Package: audacious-plugins-1.4.5-1.el5.rf.i386 (rpmforge)
    Requires: libcdio.so.7(CDIO_7)
    Available: libcdio-0.77-1.el5.rf.i386 (rpmforge)
    libcdio.so.7(CDIO_7)
    Installed: libcdio-0.81-3.1.el6.i686 (@base/$releasever)
    Not found
    Error: Package: audacious-plugins-1.4.5-1.el5.rf.i386 (rpmforge)
    Requires: libcurl.so.3
    Error: Package: libcddb-1.3.1-1.el5.rf.i386 (rpmforge)
    Requires: libcdio.so.7
    Available: libcdio-0.77-1.el5.rf.i386 (rpmforge)
    libcdio.so.7
    Installed: libcdio-0.81-3.1.el6.i686 (@base/$releasever)
    Not found
    Error: Package: audacious-plugins-1.4.5-1.el5.rf.i386 (rpmforge)
    Requires: libcdio.so.7
    Available: libcdio-0.77-1.el5.rf.i386 (rpmforge)
    libcdio.so.7
    Installed: libcdio-0.81-3.1.el6.i686 (@base/$releasever)
    Not found
    Error: Package: audacious-plugins-1.4.5-1.el5.rf.i386 (rpmforge)
    Requires: libFLAC.so.7
    You could try using --skip-broken to work around the problem
    ** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
    kernel-firmware-2.6.32-279.11.1.el6.noarch is a duplicate with kernel-firmware-2.6.32-279.el6.noarch
    selinux-policy-3.7.19-155.el6_3.4.noarch is a duplicate with selinux-policy-3.7.19-154.el6.noarch
    [root@localhost tor]#


    Disculpa ésta violación de espacio, quedo a la espera, será lo de rpmdb problem ??

    ResponderEliminar
    Respuestas
    1. Mirá, eso parece ser un problema de repos, por lo que veo, ya de entrada un repo quiere instalar cosas de CentOS 5, si mirás, dice: libcdio-0.77-1.el5.rf.i386, con lo cual, seguro que instalaste el repo de RPMforge para EL5 y no EL6.
      Segundo, deberias hacer un yum update && yum distro-sync para limpiar eso.
      Tercero, elimina el kernel viejo y selinux viejo, asi:

      yum remove kernel-firmware-2.6.32-279.el6.noarch selinux-policy-3.7.19-154.el6.noarch

      Tenés paquetes duplicados, es raro, eso suele suceder cuando hay errores en la instalacion.

      Por ultimo, si miras bien, de entrada pusiste los repos de RPMforge, de EL5 y no 6, mira:

      Available: libcdio-0.77-1.el5.rf.i386 (rpmforge)
      libcdio.so.7
      Installed: libcdio-0.81-3.1.el6.i686 (@base/$releasever)

      Eso te indica que, intenta instalar libcdio de EL5 pero el sistema BASE, posee la de EL6, con lo cual, no solo pusiste el repo de otra release, sino que ademas, no estas usando yum protect base y yum priorities, con lo cual, nunca jamas deben pisarse paquetes de la distro base, a menos que, sean casos que se pueden, como hice yo con la libvpx.so, pero es un tema aparte, antes de publicar algo lo testeo.

      Consejo?, reinstala, y mira en la wiki de centos, el apartado de repositorios de terceros, sino, vas a repetir el error.

      Eliminar
  3. SynFlag, puse otro repositorio que alcanzo a antender se ocupa de lo multimedia fuera de lo estrictamente servidores, yum install atrpms-repo.
    Instalé el audacious sin problema, tb tenía un kernel repetido o identico que lo saque con package-cleanup --dupes.
    Quise instalar el smplayer pero me alegó libgpm.so.1, bueno no es tan primordial.
    No me preocupa ser un real maestro de centos ni un sysadmin, solo tener un sistema estable y usable que tenga cierta familiaridad con la consola, muchos saludos desde Chile
    atte
    MoscaElectrica

    ResponderEliminar
    Respuestas
    1. Mira, en realidad el tema es que no usaste yum protect base y yum priorities, se pueden tener tantos repos como existan, solo que usando protect = 1 en los del sistema base, y luego prioridades, el base es 1, mientras los demas, por orden en que no te den conflicto, del 2 al numero que desees.
      Ejemplo, mira los repos que tengo instalados y activos, usando SL, sin 1 problema:

      adobe-linux-i386.repo epel-testing.repo ius-testing.repo remi.repo russianfedora-free-updates.repo sl.repo
      atrpms-bleeding.repo google-chrome.repo mirrors-rpmforge rpmforge.repo russianfedora-free-updates-testing.repo tor.repo
      atrpms.repo google-earth.repo mirrors-rpmforge-extras rpmfusion-free-updates.repo russianfedora-nonfree.repo virtualbox.repo
      atrpms-testing.repo google-talkplugin.repo mirrors-rpmforge-testing rpmfusion-free-updates-testing.repo russianfedora-nonfree-updates.repo
      dropbox.repo ius-archive.repo nux-dextop.repo rpmfusion-nonfree-updates.repo russianfedora-nonfree-updates-testing.repo
      elrepo.repo ius-dev.repo puias-addons.repo rpmfusion-nonfree-updates-testing.repo sl6x.repo
      epel.repo ius.repo puias-computational.repo russianfedora-free.repo sl-other.repo

      El tema es que uso, protect base, prioridades y ademas de ello, uso el parametro exclude=paquete paquete2 segun me interese uno mas nuevo o estable de un repo que de otro

      Eliminar
  4. Mañana voy a reinstalar y a tener cuidado con los repos y sus versiones, voy a seguir tus indicaciones, es autoexplicativo lo de protect base, feliz de aprender y tener un sistema sólido, te agradezco SynFlag por tu paciencia !
    Increíble e inspirador blog.
    MoscaElectrica

    ResponderEliminar
  5. SynFlag, sé que ya he pedido suficiente, pero casi que es necesario un tutorial para tontos para activar las repos de SL. Mi caso: primera instalación de SL, incapaz de instalar casi nada por no activar prioridades ni protección; segunda instalación de SL (por dónde voy ahora), OK, pero algunas repos no las consigo activar. Por ejemplo, PUIAS: cuando intento instalar el rpm me dice que necesito tener el repo "puias-core", y aunque no me va a servir de nada, me lo bajo también, y falla. NauLinux: ¿cómo exactamente se hace? Remi: sale en la lista de repositorios, pero no se quiere activar, ¿me faltará la llave? Nux-desktop: no me aparece en la lista, libreoffice y misc sí. ATrpms: lleva un día caído, he localizado mirrors, pero sus rpms de activación te devuelven a ATrpms.
    Aún así SL me ha convencido, de aquí ya no me muevo. Si necesito algo más moderno en un momento dado, virtualización y ya está. Ahora a ver si saco tiempo para ponerme con el kernel vanilla...

    ResponderEliminar
    Respuestas
    1. Ok, tomo tu sugerencia, y haré un post sobre el tema, ahora bien, generalmente en cada web existe un rpm que se instala con rpm -Uvh localmente o desde web y eso ya añade el repo.

      Eliminar

Ingresa tu comentario