RSS

 Seguime por RSS

22 mar. 2013

Scientific Linux 6.4 liberado

Tarde pero llegó. Así como CentOS sigue a RHEL, SL tambien lo hace.
Hace unas semanas CentOS ya tenia en sus repos las ISO y updates para 6.4, ahora le toca a Scientific Linux.
Para actualizar, si bien yum update alcanza, dado el nuevo plugin de yum en SL de 6x, lo correcto es: yum --releasever=6.4 update.

Como siempre, los link de descarga:

i686
x86_64

24 comentarios:

  1. Es la versión definitiva, ¿no? En la web aún no la anuncian...

    A mí ciertamente que hayan tardado no me importa mucho porque los cambios son pocos y apenas me afectan. Otra cosa diferente es que veo en Distrowatch que Red Hat sale con Firefox 17 de serie y CentOS (de SL 6.4 no pone nada aún) sigue con 10. No es que importe ya que utilizamos el repositorio para ir al día pero bueno, si SL quiere enfocarlo al escritorio también no debería dejar pasar cosas como éstas.

    ResponderEliminar
    Respuestas
    1. Si es la definitiva, de hecho la fecha fue 13-3-13, no lo anuncian solo porque son vagos para actualizar la web nada mas. Si te fijás no es beta ni nada, sino no estaria dentro de /6.4 en el mirror.
      Como dije, SL anda medio vago... con las updates y con todo, no se porque, por eso me pase a centos.

      Mira, no se de SL, pero en CentOS, sale con este, que esta en el mirror, en la seccion updates de 6.4: firefox-17.0.3-1.el6.centos.i686.rpm

      Por otro lado, el repo de SL de 6.4: firefox-17.0.3-1.el6_3.i686.rpm 20-Feb-2013 11:21 25M

      No se donde viste la version 10, eso era en la 6.2 de ambas, donde el ESR de Firefox era solo 10.x, ahora es 17.x, que es la version extendida en soporte.

      Eliminar
    2. En SL 6.3 que yo tengo aún es la versión 10, en 6.4 he sacado la información de Distrowatch en la tabla de programas, han actualizado CentOS a 6.4 pero sigue con Firefox 10 (insisto, en la tabla, ya veo que realmente no lo han actualizado por lo que comentas, pero en cambio a Red Hat si que le ponen 17).

      De todas maneras yo en SL no me voy a enterar cuando actualice la versión, porque seguiré con el repo de Remi...

      Eliminar
    3. Nah, pero es error de distrowatch jajaja. Si usas remi, siempre está el ultimo estable de mozilla.org, asi que ni te preocupes!

      Eliminar
    4. Pues acabo de intentar una instalación limpia de CentOS y te ponía para instalar Firefox 10, no sé si luego se actualiza o que...
      Y digo "acabo de intentar" porque al contrario que SL necesitas los dos discos de instalación y yo solo tenía uno, un detalle a favor de SL que me permitía instalar con solo uno y supongo que mete paquetes muy opciones para el escritorio en el segundo DVD.

      Eliminar
    5. Mira, yo lo instalo con uno, por red, asi que no se :S.

      10?, ya viene con 17 por defecto al menos eso decian, pero te aseguro que luego se actualiza, si en los repos de updates va por el 17 en firefox y thunderbird.

      thunderbird-17.0.5-1.el6.centos.i686

      Eliminar
    6. Me corrijo por si alguien que quiera instalar un clon de Red Hat entra: el problema al intentar instalar CentOS con un solo disco era que se había grabado mal y no que necesite los dos, solo necesita el primero como SL. Y se grabó con Xfburn sin que diera error... En otro post dijiste que estaban dudando para RH7 si poner Xfce, Gnome o Mate: para mí el mejor de los tres es Mate, Gnome 2 mejorado, actualizado y limpiado de dependencias chorras, pero no creo que RH apueste por el proyecto que en su base mantiene Linux Mint con pocas personas y que aún tiene que solucionar problemas de dependencias al instalarse junto a Gnome 3. El problema es que las alternativas no me convencen: Xfce no esta mal pero joder, ¿Xarchiver para descomprimir? Casi se peta intentando abrir compresiones de 300 megas no divididas en RAR, ¿monitor de actividades? Cutre. En Debian Testing me hice un menú personalizado para la barra de tareas, ¡tardaba de 5 a 10 segundos en abrirse! En ningún otro escritorio me ha pasado. Y Gnome 3... bueno, yo no soy tan crítico como tú, SynFlag, pero pide aceleración 3D: ¿va a parchear eso Red Hat o espera que se instale el escritorio en equipos con aceleración 3D solo?

      Eliminar
    7. Aun no lo se, pero MATE te aseguro que no, no lo van a usar. Lo que si, van a corregir obviamente los errores en lo que usen, como el que mencionas en gnome3 sobre lo 3D o no, de hecho la ultima version creo que permite usar solo 2D.
      Xfburn nunca me dio problemas, si brasero. El que mejor me anda siempre es K3B y el mejor aunque no lo parezca, usar wodim desde terminal.

      Eliminar
  2. La verdad me tiene con muy buen sabor de boca estos clones de Redhat, la verdad es que llega un momento en donde la versionitis cansa y ya se quiere un sistema estable y potente.
    Aunque no uso Centos ni SL, si uso Servos.

    ResponderEliminar
    Respuestas
    1. Asi es, bueno, servos es otro clon con algunas modificaciones, pero si, la versionitis cansa, es una etapa... es como cuando uno prueba 1 distro por semana, es una etapa.
      Si usas la pc para trabajar, nada mejor que algo estable, que funcione siempre y sin tener que andar buscando soluciones raras o hacks para que sea usable X componente.

      Eliminar
  3. SynFlag, perdona que moleste aquí, pero no supe donde más exponer mi problema.
    Uso Fedora 17 con KDE y ayer actualicé a KDE 4.10.1-1 y el kernel a 3.8.3-103. Al encender, todo va de perlas, KDE está mucho más fluido y todo funciona más rápido. No gran cosa, pero si suficiente para ser percibido. El problema está al hibernar. Antes, al regresar de hibernar salía un pequeño cuadro con el nombre del usuario y el espacio para la contraseña, ahora no aparece, dejando la pantalla negra. Y el kernel (imagino es el kernel, pues con el kernel 3.6.11-5 no sucede) acelera mis ventiladores al máximo al volver de hibernación y así los deja.
    ¿Alguna idea de como solucionar esto? He buscado por la red pero no he encontrado nada. Ojalá puedas ayudarme y te agradezco de antemano tu atención.

    ResponderEliminar
    Respuestas
    1. Mira, tengo el mismo sistema en desktop, con kernel 3.7.9, no me llego ese update, pero si el de KDE, asi que te puedo decir... que es el kernel. Seguramente la hibernacion/suspencion con tu chipset no funcione bien.
      Solucion, si, volver al kernel anterior: yum downgrade kernel
      Te aconsejo que reportes el error en bugzilla.redhat.com, en productos, Fedora, para que reporten el error a kernel.org o bien lo parcheen ellos.
      Te van a pedir, modelo de mother, cpu, etc, para poder ver el error, en producto selecciona Fedora y en el item, kernel.

      Por cierto, que mother es?, con el modelo basta, para ver su chipset y demas.

      Eliminar
    2. No sé cual es la motherboard, es la que traía por defecto y no trae especificaciones, lo checaré al rato, pues ahorita ando reinstalando u_u. Usé FedUp para actualizar mi Fedora y no arranca. Ya probé unas soluciones de internet y nada. Vaya suerte que me tocó estos días.

      Eliminar
  4. Para ver que cosas tiene tu mother, pon: lspci y dmidecode, si te dice que dmidecode no esta instalado, lo instalas: yum install dmidecode

    ResponderEliminar
  5. Hola Synflag, te molesto en este comentario porque quisiera saber si me podés orientar un poco. Hace rato vengo usando sl6 sin problemas, realmente estoy muy satisfecho. Me armé otra pc con partes que tenía por ahí y quise probar centos6. Todo bien salvo por un problemita que tengo con un adaptador wi-fi tp-link usb que tengo. Ya probé todas las opciones que encontré en internet. El firmware debería ser atheros 9k (el chip es atheros ar 9271) y como es usb, debería ser htc_9271.
    ya probe lo que dicen en los howtos de la wiki de centos
    http://wiki.centos.org/HowTos/Laptops/Wireless
    y lo que dice en linux wireless.
    básicamente no funciona nada y encuentro en un foro que se podría solucionar instalando kmod-compat-wireless, pero resulta que no funciona en centos ni sl 6.4. Cuando hago #modprobe ath9k (habiendo chequeado que el firmware este en /lib/firmware)
    carga el modulo pero en "used by" tira 0, por mas que reinicio el network manager, nada, ni siquiera me aparece con un iwconfig.
    Perdón que te joda, sé que no sos soporte de EL, pero si tenés algo para sugerirme te lo agradecería, porque no sé como seguir y no hay mucha info tyodavía (lógico) sobre los el 6.4

    ResponderEliminar
    Respuestas
    1. Mira, el used by = 0, es porque deberia cargarse al inicio. Proba con insmod, no modprobe.
      #insmod ath9k

      Por otro lado, esta el firmware en rpm del repositorio ELREPO: http://pkgs.org/centos-6-rhel-6/elrepo-i386/ath9k_htc-firmware-1.3-1.el6.elrepo.noarch.rpm.html (agrega el repo y pon yum priorities y protect base, asi ya lo usas sin tener que andar bajando el rpm)

      El mismo chipset en el foro de centos lo marcaron como RESOLVED, asi que yo que vos me leo el hilo:

      https://www.centos.org/modules/newbb/viewtopic.php?topic_id=37243

      Creo que el dmesg podria ayudar, te pone algo asi?: usb 1-3: ath9k_htc: Firmware - htc_9271.fw not found

      Y segun cuenta, con solo hacer: wget -P /lib/firmware http://wireless.kernel.org/download/htc_fw/1.3/htc_9271.fw

      Reinicia y problema solucionado. (es lo mismo que instalar el firmware desde el rpm de ELREPO)


      Leete el hilo, probá las opciones y conta como te fue

      Eliminar
  6. Sabes si el instalador tiene integrado el boot para UEFI como Fedora, te lo comento por que después de morir mi antigua maquina me compre una discreta con el jodio uefi y solo he podido instalar Fedora, por que Ubuntu ya se puede olvidar de mi.
    Hice prueba con CentOS-6.3-x86_64-netinstall-EFI.iso pero solo te instala lo mas básico y los repos dan error.
    Un saludo

    ResponderEliminar
    Respuestas
    1. Tecnicamente, RHEL y derivados van a soportar oficialmente UEFI en RHEL7, que no va a demorar tanto en salir.

      Si te instala lo mas basico no es problema, luego haces un groupinstall "X Window System" y luego gnome y asi, pero error de repos?.

      La imagen de DVD, CD1 y Minimal de CentOS tienen soporte para arranque EFI. El LiveCD no lo han publicado de ese modo.

      De todos modos ya va en 6.4 asi que quiza el error de repos era por eso... los 6.3 ya no van o no estan sincronizados.

      Mejor instalate minimal de 6.4 a ver como va

      Saludos

      Eliminar
    2. "De todos modos ya va en 6.4 asi que quiza el error de repos era por eso "

      Si posiblemente sea eso de todas maneras me baje las isos de SL 6.4 y Centos 6.4, siendo el resultado que SL todabia no tiene soporte para uefi es mas ni si quiera arrancaba en mi equipo, pero Centos 6.4 es una joya que si lo tiene fue arrancar con el y solo te puedo decir que ya ha desplazado a Fedora 18.
      Bastante contento con ello pero es una pena lo de SL que siempre fue mi clon preferido.

      Eliminar
    3. Si, los de CentOS han trabajado junto a Fedora para colocar UEFI en CentOS 6.4.

      Mira, SL tambien era mi clon preferido, pero... te daré los motivos por los cuales hace unos meses migré a CentOS:

      1.- Alla por la 6.2 en 2012, digamos que diciembre, note que las updates era selectivas, es decir, de todas las errata publicadas por Red Hat, solo algunas salian en SL, mientras en CentOS que lo tenia en una VM, salian TODAS. Cuando consulte por ello en el foro de SL, me dijeron que solo ponian las importantes y que si tenia alguna queja que hablara con el team de SL

      2.- Ademas, noté que las updates, algunas tenian 4-5 días de atraso frente a 2 días de CentOS, eso sumado a que la 6.3 de CentOS salio mas rapido, migré a CentOS

      Al día de hoy, no solo las updates de SL tienen mas demora, sino que son algo selectivas, no van cabeza a cabeza con Red Hat, sino que seleccionan las mas importantes, y si bien, gnome-desktop o GDM no son cosas vitales, esta bueno que si están disponibles se apliquen.

      Agregado a eso, me di cuenta de que mucha gente de Fedora, trabaja con CentOS ayudando en diferentes areas, como si de alguna manera, al ser algo comunitario, se sintieran identificados los de Fedora con CentOS y lo adoptaran, para sus servidores personales o de su empresa, hablo de la gente de la comunidad de Fedora que son la mayoria.

      Por ese motivo es que migré, y esto de UEFI es prueba de ello que comento.

      Eliminar
  7. Bueno esto es publicidad de centos 6.4 x64 sobre un equipo Packard Bell iMedia S2110 AMD, por cierto bastante discreto y con tarjeta ATI integrada en CPU ( que asco ) te dejo como queda su consumo y electroencefalograma ¿?

    http://img703.imageshack.us/img703/3356/centos64x64.png

    ResponderEliminar
    Respuestas
    1. Muy bonito escritorio!, los iconos y demas. 280MB en 64 bit, nada mal. Si, ni me digas sobre los ATI en CPU o APU..... la verdad una ENORME decepcion. He visto laptop con APU de AMD, que no anda el turbocore ( o sea, Linux no prioriza el turbocore de cada modelo, que parece ser distinta la funcion en cada modelo de CPU a diferencia de Intel, que funciona el turbo boost en todos los modelos), o que si no es grafica... el rendimiento del CPU puro y duro es pesimo (compilacion de un kernel, 39 minutos :S).

      La verdad que los APU de AMD los veo mas para "laptop o desktop para multimedia y office".
      Los FX, comparados a los Phenom... nada que ver, digo, cambiaron socket con lo que conlleva cambiar el mother para un rendimiento identico. Un AMD FX-6100 tiene el mismo rendimiento que un Phenom 945 x4, el primero de 6 cores a 3.3 y el segundo a 3.0 sin turbo nada, rendimiento?, el mismo... la verdad que pauperrimo lo de AMD, mas que Bulldozer deberian ponerle Faildozer.

      Lo bueno de CentOS, que noté en bugzilla.redhat.com, es que toman mas "en serio" las fallas reportadas de un CentOS como si fuera un RHEL que de un SL, asi que de paso me viene bien para pulir pavadas, digo pavadas porque habré encontrado 2 bug maximo y no relevantes.

      Eliminar
  8. hola, para qué sirve compilar un kernel? (disculpa la ignorancia). Dices que Amd es mejor compilando en linux! Vaya que bien. Por cierto, buen blog!

    ResponderEliminar
    Respuestas
    1. Gracias!, acá tenés una entrada que habla del tema, porque si, porque no.

      http://hackingthesystem4fun.blogspot.com/2012/11/como-compilar-un-custom-kernel-y-no.html

      Eliminar

Ingresa tu comentario