RSS

 Seguime por RSS

12 mar. 2012

Yum Update Error => Requires: libvpx.so.1 | CentOS - Scientific Linux

Hace unos dias (3), encontré un error, al intentar actualizar mi SL6.2.
Pese a buscar y buscar, encontre que no era un problema mio, sino de CentOS, el clon 100% compatible a nivel binario con RHEL.
El problema radica, en que la actualizacion de Audacious, implica un paquete que esta en el repo ATRPMS-TESTING, pero lo requiere desde STABLE (error de empaquetado, si).
Es un error de empaquetado, en la lista de mail, aun estan debatiendo sobre el tema, pero yo les traigo aquí la solucion. http://www.gossamer-threads.com/lists/atrpms/users/15930

El problema es el siguiente, libvpx pertenece al repo SL, o CentOS, y es parte del sistema base (RHEL), lo cual implica que no puede ni debe ser reemplazado.
Ahora bien, esta libreria, es el codec libre de reproduccion de VP8, con lo cual, no es un componente crítico, y si puede ser reemplazado. Nunca reemplazen un kernel o glibc con tanta ligereza!!.

Pasos a seguir para arreglar esto:

1.- Instalar yum priorities plugin
2.- Colocar prioridad "3" al repo RPMFORGE
3.- Colocar prioridad "2" al repo ATRPMS
4.- Activar el repo ATRPMS-TESTING con prioridad 4

Luego de esto, haremos:

# rpm -ev --nodeps libvpx gstreamer-plugins-bad-free gstreamer-plugins-bad
# yum remove ffmpeg vlc mplayer

Instalamos a mano la libreria que nos pide, la cual es:

libvpx-1.0.0-1.el6.i686 (si es de 64 bit, seria libvpx-1.0.0-1.el6.x86_64)

i686: ftp://ftp.pbone.net/mirror/atrpms.net/el6-i386/atrpms/testing/libvpx-1.0.0-1.el6.i686.rpm
x86_64: ftp://ftp.pbone.net/mirror/atrpms.net/el6-x86_64/atrpms/testing/libvpx-1.0.0-1.el6.x86_64.rpm

Hacemos wget -c con el RPM que corresponda según la arquitectura, y luego:

# rpm -Uhv --nodeps libvpx*

Luego:

# yum update

Actualizará muchas cosas, dado que ATRPMS posee cosas mas nuevas que RPMFORGE en cuanto a multimedia se refiere, incluso, VLC 2.0

Luego:

# yum install audacious ffmpeg mplayer vlc gstreamer-plugins-bad-free

Eso es todo!.

Porque sucedio esto?, facil, la nueva version de ffmpeg requiere la libreria libvpx version 1.x. En la lista de ATRPMS se discute si realmente RHEL6.2 necesita algo tan nuevo, total... es RHEL, no Fedora, y la respuesta, mia, es SI, dado que es un componente no critico, el nuevo ffmpeg trae muchas mejoras, y se empaqueto asi, dado que Fedora 15 y 16 ya lo estan usando con exito.
Mi consejo es que mantengan el repo RPMFORGE en prioridad 3, y ATRPMS en 2, dado que la mayoria de las cosas que usamos los usuarios de RHEL como desktop para multimedia, viene de RPMFORGE, pero las cosas mas nuevas, las tiene ATRPMS.

Espero les haya servido
Saludos!

3 comentarios:

  1. Buenas. Por fin siguiendo este manual he conseguido actualizar a SL6.6. Pero tengo una duda. Como se realiza lo siguiente:



    2.- Colocar prioridad "3" al repo RPMFORGE


    3.- Colocar prioridad "2" al repo ATRPMS


    4.- Activar el repo ATRPMS-TESTING con prioridad 4
    Un saludo

    ResponderEliminar
  2. Las prioridades se manejan usando el plugin yum priorities, y en cada repo se coloca el valor:

    priority=N donde N es un numero del 1 a 100.

    El repo, lo activas editando el repo, estan todos en /etc/yum.repos.d/artpms.repo y el enabled=0 lo pasas a 1, es un valor boolean.

    ResponderEliminar
  3. Muchas gracias...

    ResponderEliminar

Ingresa tu comentario