RSS

 Seguime por RSS

3 nov. 2012

Instalar Openshot en CentOS - Scientific Linux - RHEL

Algo que falta en RHEL, bueno, era de esperarse en una distro para servidores, son aplicaciones multimedia.
Si bien los players y demas estan mas que cubiertos con repos de terceros, no existen editores de video, faciles, lindos y estables como kdenlive (el que mas uso en Fedora 17 KDE).



Buscando encontré una alternativa excelente, que, esta en un repo poco frecuente, nux.

Repos necesarios:

nux-dextop
atrpms
rpmforge
epel

Atrpms, rpmforge y epel, pueden instalarlo buscando en Google, y añadiendo el rpm, en SL, ya viene en los repos, para instalar el repo, valga la redundancia!.
Para los que no hayan leido post anteriores, y/o no tengan ganas de instalar el rpm de nux-dextop, se los dejo acá, solo hagan esto:

1.- # nano /etc/yum.repos.d/nux-dextop.repo
2.- Peguen esto:

[nux-dextop]
name=Nux.Ro RPMs for general desktop use
baseurl=http://li.nux.ro/download/nux/dextop/el6/$basearch/ http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el6/$basearch/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
protect=0
priority=10
[nux-dextop-testing]
name=Nux.Ro RPMs for general desktop use - testing
baseurl=http://li.nux.ro/download/nux/dextop-testing/el6/$basearch/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
protect=0
Aclaro para el que no lee bien y detenidamente, deben, si o si, tener instalado yum-plugin-priorities, y configurado, sino, les pisará cosas del sistema, u otros repos.

Dicho esto, pasemos a lo que sigue....

3.- # yum install openshot

Verán algo como esto (los repos pueden cambiar, los paquetes que ven los saca de cada uno en mi caso porque tengo mis prioridades asi configuradas)


Luego de que termine el proceso yum, openshot estará listo para ser usado.
Es todo!.

5 comentarios:

  1. Buenas.

    Me da errores de conflictos cuando he ido a instalarlo.

    Transaction Summary
    =======================================================================================================================================================================
    Install 29 Package(s)

    Total size: 29 M
    Total download size: 23 M
    Installed size: 104 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/15): PIL-1.1.7-10.1.el6.x86_64.rpm | 407 kB 00:04
    (2/15): SDL_image-1.2.10-1.el6.rf.x86_64.rpm | 84 kB 00:00
    (3/15): frei0r-plugins-1.3-5.el6.nux.x86_64.rpm | 372 kB 00:03
    (4/15): gavl-1.2.0-2.el6.nux.x86_64.rpm | 2.6 MB 00:26
    (5/15): goocanvas-1.0.0-1.el6.nux.x86_64.rpm | 137 kB 00:01
    (6/15): jack-audio-connection-kit-0.118.0-1.el6.x86_64.rpm | 161 kB 00:03
    (7/15): libavdevice53-0.10.2-54.el6.x86_64.rpm | 34 kB 00:00
    (8/15): libgdither-0.6-4.el6.nux.x86_64.rpm | 17 kB 00:00
    (9/15): libquicktime0-1.2.3-30.el6.x86_64.rpm | 185 kB 00:01
    (10/15): mlt-0.7.8-1.el6.nux.x86_64.rpm | 2.2 MB 00:23
    (11/15): mlt-python-0.7.8-1.el6.nux.x86_64.rpm | 95 kB 00:00
    (12/15): openshot-1.4.2-4.el6.nux.noarch.rpm | 16 MB 02:49
    (13/15): pygoocanvas-0.14.1-3.el6.nux.x86_64.rpm | 55 kB 00:00
    (14/15): python-httplib2-0.7.4-6.el6.noarch.rpm | 69 kB 00:03
    (15/15): sox-14.2.0-6.el6.x86_64.rpm | 375 kB 00:05
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Total 93 kB/s | 23 MB 04:13
    Running rpm_check_debug
    Running Transaction Test


    Transaction Check Error:
    file /usr/lib64/libavdevice.so.53.4.100 conflicts between attempted installs of libavdevice53-0.10.2-54.el6.x86_64 and ffmpeg-libs-0.10.4-1.el6.nux.x86_64
    file /usr/lib64/libavformat.so.53.32.100 conflicts between attempted installs of libavformat53-0.10.2-54.el6.x86_64 and ffmpeg-libs-0.10.4-1.el6.nux.x86_64
    file /usr/lib64/libswscale.so.2.1.100 conflicts between attempted installs of libswscale2-0.10.2-54.el6.x86_64 and ffmpeg-libs-0.10.4-1.el6.nux.x86_64
    file /usr/lib64/libavutil.so.51.35.100 conflicts between attempted installs of libavutil51-0.10.2-54.el6.x86_64 and ffmpeg-libs-0.10.4-1.el6.nux.x86_64

    Error Summary
    -------------



    Un saludo

    ResponderEliminar
    Respuestas
    1. Tenes instalado el plugin de yum protect base y activado en /etc/yum.repos.d/foo.repo ?

      Eliminar
  2. I am also having the same problem!

    ResponderEliminar
  3. What problem?, I have installed 0 problem:

    openshot-1.4.3-1.el6.nux.noarch
    /usr/bin/python
    SDL
    fontconfig
    frei0r-plugins
    hicolor-icon-theme
    librsvg2
    mlt
    mlt-python
    notify-python
    pygoocanvas
    pygtk2-libglade
    python(abi) >= 2.5
    python(abi) = 2.6
    python-httplib2
    python-imaging
    pyxdg
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(FileDigests) <= 4.6.0-1
    rpmlib(PartialHardlinkSets) <= 4.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    sox
    rpmlib(PayloadIsXz) <= 5.2-1

    ResponderEliminar
  4. Sir, I am facing the problem of

    ResponderEliminar

Ingresa tu comentario